We have deployed a patch that should get artist gem prices and new music back up. Please note that this is a quick patch instead of a long term fix. We are monitoring and we'll continue to work on the long term fundamental fix.
Posted Oct 09, 2025 - 21:42 UTC
Investigating
We are currently investigating this issue.
Posted Oct 09, 2025 - 19:37 UTC
This incident affects: New Music and Artist Gem Prices.